FULL SPECTRUM FORUM

An unofficial forum for Full Spectrum Laser users
It is currently Tue Aug 22, 2017 5:40 pm

Contact Us | All times are UTC - 6 hours [ DST ]



Welcome
Welcome to fslusers

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 7:40 am 
Offline

Joined: Sun Jul 23, 2017 4:32 pm
Posts: 12
Country: Kuwait
Laser Type: 5th Gen
Hello,

I am new to RE and found there is a feature called material test. Unfortunately, it only does the first row.

Any idea how to fix it?


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 9:17 am 
Offline

Joined: Tue May 16, 2017 2:27 pm
Posts: 43
Country: USA
Laser Type: 5th Gen Model A
I had this problem for a while, but I haven't had it fail for some time. Here are a few questions. The answers to these will help people help you. I'm sure others will jump in:

1. How are you connected to the laser? USB or ethernet?
Ethernet has been much more reliable for me.

2. When the material test stops running, what state is the laser in? What does the front panel say? What does the RE screen say?

3. What did you have to do to get the laser working again? Did you have to power cycle the laser? Did you have to stop and restart RE?

4. Have you tried this multiple times? (I know from your other question you posted elsewhere that it sounds like you have, but people reading this later won't know you posted in other areas of the forum at the same time, so it's best to get that information all in one place.)

5. If you tried it multiple times, was there a pattern to where it stopped working?

6. If you tried it multiple times, was there a pattern to what it took to get the laser talking to RE again?

--------

The material test communicates with the laser quite a bit. So, when it fails, it is often a communications issue.


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 9:26 am 
Offline

Joined: Sun Jul 23, 2017 4:32 pm
Posts: 12
Country: Kuwait
Laser Type: 5th Gen
Thank you for your reply

1. How are you connected to the laser? USB or ethernet?

Ethernet


2. When the material test stops running, what state is the laser in? What does the front panel say? What does the RE screen say?

After doing the first row (7 squares) it goes back to the first position. The machine screen says idle. The RE sticks to the process message where it says (1/10) pass - Press (C) to cancel. And it doesn't change

3. What did you have to do to get the laser working again? Did you have to power cycle the laser? Did you have to stop and restart RE?

Pressing C will cancel the process

4. Have you tried this multiple times? (I know from your other question you posted elsewhere that it sounds like you have, but people reading this later won't know you posted in other areas of the forum at the same time, so it's best to get that information all in one place.)

Yes I did.same result

5. If you tried it multiple times, was there a pattern to where it stopped working?
After doing the firs row

6. If you tried it multiple times, was there a pattern to what it took to get the laser talking to RE again?
No


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 9:52 am 
Offline

Joined: Tue May 16, 2017 2:27 pm
Posts: 43
Country: USA
Laser Type: 5th Gen Model A
Well, the good news for me is that the material test works for gen 5 model A lasers, which is what I have. I had forgotten I had read that it doesn't work for Gen B models. After reading your answers, I realized the failure mode sounded familiar. Here's the thread I found when searching the forum:

viewtopic.php?f=4&t=817

So, it appears this is a known bug. From other threads, it doesn't look like it will be fixed.


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 11:17 am 
Offline
Site Admin

Joined: Thu Jun 13, 2013 6:11 pm
Posts: 1125
Country: USA
Laser Type: 4th and 5th
If you are experiencing this bug, please contact Full Spectrum. If no one complains they won't fix bugs- they have been promising new versions of software for literally two years and they haven't released a single patch :(

_________________
40W Gen 4, 80W Gen 5 with Rotary, RigidBot 3D printer, LittleRP 3D printer, screwdrivers.

Please remember this is an unofficial forum and is unaffiliated with Full Spectrum. All moderators and admins are volunteers!


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 12:12 pm 
Offline

Joined: Sun Jul 23, 2017 4:32 pm
Posts: 12
Country: Kuwait
Laser Type: 5th Gen
Oh I see

So it is a dead end

Any other software that can be used ?


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 1:43 pm 
Offline
Site Admin
User avatar

Joined: Wed Jun 05, 2013 2:10 pm
Posts: 1178
Country: United States
Laser Type: 5th Gen
Personally I've never even used the material test function..

_________________
I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives.


Full Spectrum 5th Generation with 45 watt tube and rotary attachment.

Full wood shop and welding equipment.


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Thu Jul 27, 2017 4:18 pm 
Offline

Joined: Sun Jul 23, 2017 4:32 pm
Posts: 12
Country: Kuwait
Laser Type: 5th Gen
well. In US it is easy to get the materials. Here, no one stocks materials such as rubber and leather. Therefore, it is not easy to waste them cuz shipping itself is a lot. I paid 1500$ for the machine's shipping


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Fri Jul 28, 2017 12:27 am 
Offline
User avatar

Joined: Fri Jun 07, 2013 3:54 pm
Posts: 1022
Location: Morgan Hill, CA
Country: United States
Laser Type: 5th Gen, 45w
I don't recommend rubber. Instantly ended up with a giant sooty mess in my machine. Took a long time to get rid of it. I only cut a 1" circle.

_________________
Current Equipment: FSE 45w Deluxe CO2 Laser 5th Gen w/ Rotary
South San Francisco Bay Area - Sales and Support Representative for Full Spectrum Engineering
White Light Laser, Morgan Hill, CA - - 408-47-LASER - - Skype: whitelightlaser-thomas


Top
 Profile  
 
 Post subject: Re: Problem : Material Test Feature Does Not Work in RE
PostPosted: Fri Jul 28, 2017 12:25 pm 
Offline

Joined: Mon Apr 25, 2016 5:24 pm
Posts: 193
Country: USA
Laser Type: FSLaser 5th Gen
@masktales Since it sounds like you have a 5th Gen B (BeagleBone controller) you should be aware of a few other 'Features' of the RetinaEngrave and the Laser. It's better you know sooner rather than later like I did and don't waste precious material.

IF you have a Rotary, when Rotary is selected RetinaEngrave it will cause the Trace Perimeter function to run Counter Clockwise instead of Clockwise like it's supposed to. It also causes your Job/Artwork to engrave upside down. You will have to click the Mirror Image Horizontally button so that your artwork appears upside down/backwards. This will cause it to engrave normally. If you're in doubt you can put a post it note on you glass or tumbler and run a raster at S100 and P10-15 to see which way it's going.

The other issue is the Raster THEN Vector Feature. The Raster will run fine but when it gets to the Vector portion of the job it drops the power to a fraction of what it's actually set for. The result being if you have a logo that you want to Raster then have it do a Vector Cut, it will raster but will never cut the material causing more loss. You have to remember to Raster and Vector in separate steps.

I'm with you on the Material Test. I know some say they never use it but personally I was looking forward to it since it was advertised. I'd like to be able to have a catalog of different materials with what the edges look like for Vector Cuts and Marks. Like you said it's a waste of material and very time consuming to test a bunch of different settings manually. I end up settling for what works instead of seeing a variety of options side by side to pick on that may be better than another for Speed vs Power. Although not ideal you can CTRL-C to get out of the Material Test's never ending wait and then manually change the settings for the 7 blocks that are created then save it for future tests.

Good luck!

_________________
Full Spectrum 5th Gen B 45 watt with Rotary - ActiveAqua Chiller & Pump
Shapeoko 3 CNC - KNK Vinyl Cutter - Abrasive Cabinet


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

Contact Us | All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred